B1028 人口普查 (20分)

1028 人口普查 (20分)

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:
输入在第一行给出正整数 N,取值在(0,10​5 ];随后 N 行,每行给出 1 个人的姓名(由不超过 5 个英文字母组成的字符串)、以及按 yyyy/mm/dd(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:
在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:
3 Tom John

题目大意:

求年龄最大和最小的。

思路:

将日期进行转换,然后对整数的比较。

  • 需要特判 所有输入都不在范围的时候,不然会格式错误。
#include <stdio.h>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
int main(){
	int n;
	int count=0;
	int max = 2014*12*30 +9*30+6;
	int min = 653315;
	scanf("%d",&n);
	string maxName="",minName="";
	int maxB=0,minB=100000000;
	while(n--!=0){
		string name,birth;
		cin >> name >> birth;
		string s1=birth.substr(0,4); 
		string s2=birth.substr(5,2);
		string s3=birth.substr(8,2);
		int a = stoi(s1)*12*30 +stoi(s2)*30+stoi(s3);
		if(a<=max&&a>min){
			count++;
			if(a>maxB){
				maxB=a;	
				maxName = name;
			}
			if(a<minB){
				minB=a; 
				minName = name; 
			}
		}
	}
	if(count==0){
		cout << 0;
	}else
	cout << count << " " << minName << " " << maxName ;
	
	return 0;
}

version 2
修改其实输入的时候用scanf直接就可以输入数字了,不用这么麻烦去转换。
把时间从126ms降到了73ms

#include <stdio.h>
#include <string>
#include <iostream>
using namespace std;
int main(){

	int count=0,n,min = 1814*12*30+9*30+6,max = min+200*12*30;
	scanf("%d",&n);
	string maxName="",minName="";
	int maxB=0,minB=100000000;
	while(n--!=0){
		string name,birth;
		int a1,a2,a3;
		cin >> name;
		scanf("%d/%d/%d",&a1,&a2,&a3);
		int a = a1*12*30 +a2*30+a3;
		if(a<=max&&a>=min){
			count++;
			if(a>maxB){
				maxB=a;	
				maxName = name;
			}
			if(a<minB){
				minB=a; 
				minName = name; 
			}	}	}
	if(count==0){
		cout << 0;
	}else
	cout << count << " " << minName << " " << maxName ;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wvdon

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值