MOOC程序设计期中考试1.2

#include <iostream>
#include <list>
using namespace std;
// 在此处补充你的代码
int main()
{
int t;
cin >> t;
list<int> lst;
while( t--) {
int n;
cin >> n;
lst.clear();
int m;
for( int i = 0;i < n; ++i) {
cin >> m;
lst.push_back(m);
}
lst.sort(MyLess());
list<int>::iterator it;
for( it = lst.begin(); it != lst.end(); ++ it) {
cout << * it  << " ";
}
cout << endl;
}
return 0;
}
输入
第一行是整数 t,表示数据组数。
每组输入数据一行。先是整数n(0 < n < 100),表示本组数据共有n个整数。然后跟着是n个整数。所有整数都非负且小于10000。
输出
对每组输入数据,输出一行:按要求依次输出这n个整数,相邻整数间用一个空格隔开。
样例输入
2
4 123 37 32 52
6 34 56 17 81 900 32
样例输出
37 123 52 32
17 56 34 32 81 900
#include <iostream>
#include <list>
using namespace std;

class MyLess
{
public:
	bool operator()(const int &c1,const int &c2)
	{
		if ((c1%10) != (c2%10))
		return (c1%10)>(c2%10);
		else
		return c1>c2;
	}
};
int main()
{
	int t;
	cin >> t;
	list<int> lst;
	while( t--) {
		int n;
		cin >> n;
		lst.clear();
		int m;
		for( int i = 0;i < n; ++i) {
			cin >> m;
			lst.push_back(m);
		}
		lst.sort(MyLess());
		list<int>::iterator it;
		for( it = lst.begin(); it != lst.end(); ++ it) {
			cout << * it  << " ";
		}
		cout << endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值