HDU5661 XOR



Problem Description
Claris loves bitwise operations very much, especially XOR, because it has many beautiful features. He gets four positive integers a,b,c,d that satisfies ab and cd . He wants to choose two integers x,y that satisfies axb and cyd , and maximize the value of x XOR y . But he doesn't know how to do it, so please tell him the maximum value of x XOR y .
 

Input
The first line contains an integer T(1T10,000) ——The number of the test cases.
For each test case, the only line contains four integers a,b,c,d(1a,b,c,d1018) . Between each two adjacent integers there is a white space separated.
 

Output
For each test case, the only line contains a integer that is the maximum value of x XOR y .
 

Sample Input
   
   
2 1 2 3 4 5 7 13 15
 



Sample Output
    
    
6 11
Hint
In the first test case, when and only when $x=2,y=4$, the value of $x~XOR~y$ is the maximum. In the second test case, when and only when $x=5,y=14$ or $x=6,y=13$, the value of $x~XOR~y$ is the maximum.







#include<cstdio>
using namespace std;
int main()
{
    int T;
    long long a,b,c,d,x,y,t;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld%lld%lld%lld",&a,&b,&c,&d);
        t=1;
        t=t<<62;
        for(x=0,y=0;t>=1;t=t/2)
        {
            if(d>=y+t&&a<x+t)
            y+=t;
            else if(b>=x+t&&c<y+t)
            x+=t;
            else if(c>=y+t&&a>=x+t)
            {
                x+=t;
                y+=t;
            }
        }
        printf("%lld\n",x^y);
    }
    return 0;
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值