【计算几何】Exactness of Projectile Hit

In the problem you are to determine the minimal diameter that may compensate inexactness of
projectile hit in each concrete case. Assume that all the targets are convex polygons. A hit
is the situation when the circle crater that the projectile leaves (the crater diameter equals
to the one of the projectile) covers if only one point of the target.
Input
The first line contains three numbers — coordinates of the hit point of the projectile center
and the number of polygon sides N (3 ≤ N ≤ 100). The next N lines contain the vertices
coordinates in counter-clockwise order. All the coordinates are integers from [−2000,2000].
Output
You are to output the only number which is the minimal diameter of a projectile that will cover
the target rounded with three digits after the decimal point.

Problem illustration

Sample Input:
2 -1 8
0 1
1 0
2 0
3 1
3 2
2 3
1 3
0 2

Sample Output
2.000
此题考察点到凸多边形的距离,也即:
判断点与凸多边形的位置关系以及点到线段的距离。

判断点与凸多边形的位置关系的方法如下:
假设这个点为P,凸多边形为A1A2...An,(逆时针顺序。)那么依次计算向量PA1与向量PA2, 向量PA2与向量PA3, ..., 向量PAn与向量PA1的外积。若发现一个外积小于零,那么P在凸多边形外,否则P不在凸多边形外。

计算点到线段的距离的方法如下:
假设这个点为S,线段为AB。
如果∠A为钝角(用内积判断),那么距离为SA;
如果∠B为钝角,那么距离为SB;
否则距离为S到AB的垂线段的长度(用法向量可以算)。
Accode:

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <complex>

using std::complex;
const char fi[] = "ural1215.in";
const char fo[] = "ural1215.out";
const int maxN = 110;
const double MAX = 1e198;
const double MIN = -MAX;
const double zero = 1e-12;

typedef complex <double> vec;
	//这里用复数来代替向量。
vec p[maxN];
vec res[maxN];
vec S;
int n, x, y, top;

void init_file()
{
    freopen(fi, "r", stdin);
    freopen(fo, "w", stdout);
    return;
}

void readdata()
{
    scanf("%d%d%d", &x, &y, &n);
    S = vec((double)x, (double)y);
    for (int i = 0; i < n; ++i)
    {
        scanf("%d%d", &x, &y);
        p[i] = vec((double)x, (double)y);
    }
    return;
}

template <typename _Tp>
_Tp outer_product(const complex <_Tp> a,
                  const complex <_Tp> b)
{
    return a.real() * b.imag()
    - a.imag() * b.real();
} //计算向量a, b的外积。

template <typename _Tp>
_Tp inner_product(const complex <_Tp> a,
                  const complex <_Tp> b)
{
    return a.real() * b.real()
    + a.imag() * b.imag();
} //计算向量a, b的内积。

template <typename _Tp>
_Tp dist(const complex <_Tp> S,
         const complex <_Tp> a,
         const complex <_Tp> b)
{
    vec _Sa = a - S,
    _Sb = b - S,
    _ab = b - a;
    if (inner_product(_Sa, _ab) > -zero)
        return abs(_Sa);
    if (inner_product(_Sb, _ab) < zero)
        return abs(_Sb);
    vec _norm = _ab * vec(0, 1);
	//计算向量AB的法向量
	//(即把AB逆时针旋转90°,
	//即用AB对应的复数乘以i)。
    return fabs(inner_product(_norm, _Sa)) / abs(_norm);
} //得到点S到线段AB的距离。

void work()
{
    int pos = 0;
    double ans = MAX;
    bool outside = false;
    for (int ths = 0; ths < n; ++ths)
    {
        int next = (ths + 1) % n;
        outside = outside ||
        outer_product(p[ths] - S,
        p[next] - S) < -zero;
        ans = std::min(ans, dist(S, p[ths], p[next]));
    }
    if (!outside)
    {
        printf("0");
        return;
    }
    printf("%.3lf", ans * 2);
    return;
}

int main()
{
    init_file();
    readdata();
    work();
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出图像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出图像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断图像中的目标属于哪个类别。 定位问题:确定目标在图像中的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入图像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测值。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值