Problem Description
Zero has an old printer that doesn't work well sometimes. As it is antique, he still like to
use it to print articles. But it is too old to work for a long time and it will certainly wear
and tear, so Zero use a cost to evaluate this degree.
One day Zero want to print an article which has N words, and each word i has a cost Ci to be
printed. Also, Zero know that print k words in one line will cost
M is a const number.
Now Zero want to know the minimum cost in order to arrange the article perfectly.
Input
There are many test cases. For each test case, There are two numbers N and M in the first line
(0 ≤ n ≤ 500000, 0 ≤ M ≤ 1000). Then, there are N numbers in the next 2 to N + 1 lines.
Input are terminated by EOF.
Output
A single number, meaning the mininum cost to print the article.
Sample Input
5 5
5
9
5
7
5
Sample Output
230
此题考察斜率优化的动态规划。朴素方程:f[i] = min(f[j] + sqr(s[i] - s[j]) + m),
可得到斜率不等式:
f[j] - f[k] + sqr(s[j]) - sqr(s[k])
——————————————————— >= 2s[i]
s[j] - s[k]
注意s[j]可能等于s[k],所以斜率为0的情况需要特殊判断。
Accode:
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <bitset>
#include <algorithm>
const char fi[] = "print_article.in";
const char fo[] = "print_article.out";
const int maxN = 500010;
typedef long long int64;
int64 F[maxN], s[maxN];
int q[maxN];
int n, m, f, r;
void init_file()
{
freopen(fi, "r", stdin);
freopen(fo, "w", stdout);
return;
}
inline int getint()
{
int res = 0; char tmp;
while (!isdigit(tmp = getchar()));
do res = (res << 3) + (res << 1) + tmp - '0';
while (isdigit(tmp = getchar()));
return res;
}
void readdata()
{
s[0] = 0;
for (int i = 1; i < n + 1; ++i)
(s[i] = getint()) += s[i - 1];
return;
}
#define sqr(x) ((x) * (x))
#define check(j, k, i) \
(F[j] - F[k] + sqr(s[j]) - sqr(s[k]) \
<= s[i] * (s[j] - s[k]) << 1)
#define cmp(j, k, i) \
(s[j] == s[k] ? (F[j] < F[k]) : \
(s[k] == s[i] ? (F[k] > F[i]) : \
(F[j] - F[k] + sqr(s[j]) - sqr(s[k])) \
* (s[k] - s[i]) \
<= (F[k] - F[i] + sqr(s[k]) - sqr(s[i])) \
* (s[j] - s[k])))
int64 work()
{
f = 0, r = 1;
for (int i = 1; i < n + 1; ++i)
{
while (f < r - 1 && !check(q[f], q[f + 1], i)) ++f;
F[i] = F[q[f]] + sqr(s[i] - s[q[f]]) + m;
while (f < r - 1 && !cmp(q[r - 2], q[r - 1], i)) --r;
q[r++] = i;
}
return F[n];
}
int main()
{
init_file();
while (scanf("%d%d", &n, &m) == 2)
{
readdata();
printf("%I64d\n", work());
}
return 0;
}
#undef sqr
#undef check
#undef cmp