1014 Waiting in Line (30 分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.

At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

Solution Code:

  • 如果顾客17:00之前没有被服务,就输出Sorry。
/***************************
每一个窗口便是一个队列。
哪一个队列的元素最少,黄线外的消费者优先进入哪一个队列。
队列未满时允许消费者进入队列。
******************************/
#include <iostream>
#include <queue>
#include <cstdio>
using namespace std;

int customers_minutes[1002]; //消费者的花费时间 1~1001
int windows_minutes[22] = {0}; //每个窗口的分钟累计 1~21
int done_minutes[1002] = {0}; //消费者完成时间 1~1001
queue<int> windows[22]; // 窗口1~21

void getDoneTime(int windows_numbers, int max_numbers, int customers_numbers)
{
	// 安排最大数量的消费者进入黄线内
	int customers_id = 0; 
	for (int i = 0; i < max_numbers; ++i) {
		for (int j = 1; j <= windows_numbers; ++j) {
			windows[j].push(++customers_id);
		}
	}

	// 移除消费者,直至所有消费者
	for (int j = 0; j < customers_numbers; ++j) {
		int early_time = 99999999;
		int early_windows;
		// 计算最先办完业务的人
		for (int i = 1; i <= windows_numbers; ++i) {
			if (!windows[i].empty() && done_minutes[windows[i].front()] == 0){
				// 当前窗口第一个消费者完成业务的时间
				done_minutes[windows[i].front()] = windows_minutes[i] + customers_minutes[windows[i].front()];
				windows_minutes[i] = done_minutes[windows[i].front()];
			}
			if (!windows[i].empty() && done_minutes[windows[i].front()] < early_time) {
				early_time = done_minutes[windows[i].front()];
				early_windows = i;
			}
		}
		
		windows[early_windows].pop(); // 移除最先办理完业务的消费者	

		// 黄线外有人
		if (customers_id < customers_numbers) { 
			windows[early_windows].push(++customers_id);
		}
	}
}

int main()
{
	int n, m, k, q;
	cin >> n >> m >> k >> q;
	for (int i = 1; i <= k; ++i)
		cin >> customers_minutes[i];

	getDoneTime(n, m, k);
	
	// query
	int number;
	for (int i = 0; i < q; ++i) {
		cin >> number;
		// 开始时间>=540,输出Sorry
		if (done_minutes[number] - customers_minutes[number] >= 540)
			cout << "Sorry" << endl;
		else {
			int hour = done_minutes[number] / 60;
			int minutes = done_minutes[number] % 60;
			printf("%02d:%02d\n", hour + 8, minutes);
		}
	}

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值