1102 Invert a Binary Tree

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.

Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

解题思路:就是简单的二叉树遍历

#include<iostream>
#include<stdio.h>
#include<queue>
#include<vector>
using namespace std;
struct node{
    char left;
    char right;
};
node tree[15];
int cou = 0,n;
void levelShow(int root){
    queue<int>temp;
    temp.push(root);
    printf("%d", root);
    temp.pop();
    if (tree[root].right != '-'){
        temp.push(tree[root].right - '0');
    }
    if (tree[root].left != '-'){
        temp.push(tree[root].left - '0');
    }
    while (!temp.empty()){
        int show = temp.front();
        temp.pop();
        if (tree[show].right != '-'){
            temp.push(tree[show].right - '0');
        }
        if (tree[show].left != '-'){
            temp.push(tree[show].left - '0');
        }
        printf(" %d", show);
    }
}
void invertedShow(int root){
    if (tree[root].right != '-'){
        int right = tree[root].right - '0';
        invertedShow(right);
    }
    printf("%d", root);
    cou++;
    if (cou != n){
        printf(" ");
    }
    if (cou == n){
        printf("\n");
    }
    if (tree[root].left != '-'){
        int left = tree[root].left - '0';
        invertedShow(left);
    }
}
int main(){
    for (; scanf("%d", &n) != EOF;){
        int flag[15] = { 0 };
        for (int i = 0; i < n; i++){
            char left, right;
            scanf("\n%c %c", &left, &right);
            tree[i].left = left;
            tree[i].right = right;
            if (left != '-'){
                flag[left - '0']++;
            }
            if (right != '-'){
                flag[right - '0']++;
            }
        }
        //寻找根节点
        int root = 0;
        for (int i = 0; i < n; i++){
            if (flag[i]){
                continue;
            }
            root = i;
            break;
        }
        levelShow(root);
        printf("\n");
        cou = 0;
        invertedShow(root);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值