F(x) HDU - 4734

15 篇文章 0 订阅
4 篇文章 0 订阅

F(x)

 HDU - 4734 

For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).

Input

The first line has a number T (T <= 10000) , indicating the number of test cases. 
For each test case, there are two numbers A and B (0 <= A,B < 10 9)

Output

For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.

Sample Input

3
0 100
1 10
5 100

Sample Output

Case #1: 1
Case #2: 2
Case #3: 13

 

题目大意:

给定多项式,对应的An表示对应的输入十进制数字的各个位数,

再给定数字A,B ,求在[0,B]区间内满足 f(i)<=f(A) 的i的个数。

解题思路:

参考:https://blog.csdn.net/wust_zzwh/article/details/52100392

代码:

#include<iostream> 
#include<stdio.h>
#include<cstring>
using namespace std;
int a[12];
const int MAXN = 1e4+5;
int dp[12][MAXN];
int A,B;
int all;
int f(int x){
	if(x==0) return 0;
	int ans = f(x/10);
	return ans*2+x%10;
}
int dfs(int pos,int sum,bool limit){
	if(pos <= -1 && sum<=all) return 1;
	if(sum>all) return 0;
	if(!limit&&dp[pos][all - sum]!=-1) return dp[pos][all - sum];
	
	int up = limit?a[pos]:9;
	
	int res =0;
	for(int i=0;i<=up;i++){
		res += dfs(pos-1,sum+i*(1<<pos),limit && i==a[pos]);
	}
	if(!limit) dp[pos][all - sum] = res;
	return res;
}
int slove(int input){
	int pos = 0;
	while(input>0){
		a[pos++] = input%10;
		input/=10;
	}
	int res = dfs(pos-1,0,true);
	return res;
}
int main(){
	int caseT;
	scanf("%d",&caseT);
	memset(dp,-1,sizeof(dp));
	for(int i=1;i<=caseT;i++){
		scanf("%d %d",&A,&B);
		all = f(A);
		int res = slove(B);
		printf("Case #%d: %d\n",i,res);
	}
	return 0;
}

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值