hdu1029 Ignatius and the Princess IV(DP求数列中出现次数过半的数)

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 21507    Accepted Submission(s): 8921


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
  
  
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
  
  
3 5 1
 

题意:给定一个奇数n以及n个数,求其中出现次数至少为(n+1)/2的数。

因为要求数个数过半,所以如果存在,必只有一个。这个题还是会用到DP的思想:若a为n个数中出现次数过半的数,则去掉2k(k为整数)个数,当这2k个数不存在出现次数超过k的数时,剩余n-2k个数中出现次数过半的数仍是a。

所以,定义两个变量分别为x、y,分别记录当前出现次数过半的数,当下一个数等于x时,y加一;当下一个数不等于x时,y减一。当y等于零时,说明x在前2k(k为前一阶段y的最大值)个数中出现次数不过半,即可不考虑这2k个数,将x赋值为下一个新数,y赋值为1,重复上一个步骤。

在这个方法中,只需要用一个空间来存储数列,用一个扔一个,不需要开一个特别大的数组,比如这道题n的最大值是1e6-1,大大的减小了空间复杂度。

#include <cstdio>
#include <iostream>
#include <algorithm>

using namespace std;

int main()
{
    //freopen("in.txt","r",stdin);
    int x, y, n, a;
    while(scanf("%d",&n) != EOF)
    {
        scanf("%d",&a);
        x = a;
        y = 1;
        for(int i = 1; i < n; i++)
        {
            scanf("%d",&a);
            if(x == a)
                y++;
            else if(y > 0)
                y--;
            else
            {
                x = a;
                y = 1;
            }
        }
        printf("%d\n",x);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值