hdu1027 Ignatius and the Princess II(全排列)

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5774    Accepted Submission(s): 3398


Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 

Sample Input
  
  
6 4 11 8
 

Sample Output
  
  
1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10
 


题意:给定两个整数N、M。将1~N排列组合,按字典序从小到大排列,求出排在第M个的排列。

虽然N的范围很大,到1000,1000的阶乘很吓人呀,但是M的范围只到10000,而8的阶乘就已经超过10000了,所以无论N多大,我们最多只要考虑后八位的排列组合问题。

先判断M与阶乘数的大小,确定要考虑后几位的排列组合。假设是考虑后x位的排列组合,先将1~N-x-1顺序输出。然后处理剩余的数:用M对(x-1)的阶乘求商a,取余赋值给M自身。若M为0,则倒数第x位取第a大的数,剩余几位倒序排列;若M不为0,则倒数第x位取第(a+1)大的数,再用同样方法考虑后(x-1)位数,以此类推。

#include <cstdio>
#include <iostream>
#include <algorithm>

using namespace std;

int biao[9]= {1,1,2,6,24,120,720,5040,40320};

int main()
{
    int n,m,x,a,cnt;
    int rest[2],store[9];
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i = 0; i < 9; i++)
            store[i] = 1005;
        for(int i = 1; i <= 8; i++)
            if(biao[i] > m)
            {
                x = i;
                break;
            }
        for(int i = 1; i <= n - x; i++)
            printf("%d ",i);
        for(int i = 1; i <= x; i++)
            store[i] = n - x + i;
        for(int i = x - 1; i >= 1; i--)
        {
            sort(store, store + 9);
            a = m / biao[i];
            m %= biao[i];
            if(m)
            {
                printf("%d ",store[a]);
                store[a] = 1005;
            }
            else
            {
                printf("%d ",store[a - 1]);
                store[a - 1] = 1005;
                break;
            }
        }
        sort(store, store + 9);
        for(int i = 8; i > 0; i--)
            if(store[i] != 1005)
                printf("%d ",store[i]);
        printf("%d\n",store[0]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值