POJ2533 Longest Ordered Subsequence(最长递增子序列)

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 38934 Accepted: 17094

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

题意:长度为n的数列,求最长递增子序列的长度。

法一:动态规划,时间复杂度O(N²):

dp[i]表示以第i个为结尾的数列的最长子序列长度,等于该数之前的最长子序列(该数大于子序列的最大数)的长度加一。

#include <cstdio>
#include <iostream>
#include <algorithm>

using namespace std;

int a[1005],dp[1005];

int main()
{
    int n,maxn,ans;
    while(scanf("%d",&n) != EOF) {
            ans = 0;
        for(int i = 0; i < n; i++) {
            scanf("%d",&a[i]);
            maxn = 0;
            for(int j = 0; j < i; j++)
            {
                if(dp[j] > maxn && a[i] > a[j])
                    maxn = dp[j];
            }
            dp[i] = maxn + 1;
            ans = max(ans, dp[i]);
        }
        printf("%d\n",ans);
    }
}

法二:时间复杂度O(NlogN):

每输入一个值,用二分查找找到它的位置,顶替该位置的数,保持数列递增。最后得到的数列长度就是最长子序列长度,但不是最长子序列。

#include <cstdio>
#include <iostream>
#include <algorithm>

using namespace std;

int a[1005],n,num,ans,p;

int erfen(int num, int a[])
{
    int l = 0, r = n, mid;
    while(l < r) {
        mid = (l + r) >> 1;
        if(num <= a[mid])
            r = mid;
        else if(num > a[mid])
            l = mid + 1;
    }
    return r;
}

int main()
{
    while(scanf("%d",&n) != EOF) {
        for(int i = 0; i < 1005; i++)
            a[i] = 10005;
        for(int i = 0; i < n; i++) {
            scanf("%d",&num);
            p = erfen(num,a);
            if(a[p] == 10005)
                ans ++;
            a[p] = num;
        }
        printf("%d\n",ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值