Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).
Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.
Output Specification:
For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.
Sample Input:
4
0.1 0.2 0.3 0.4
Sample Output:
5.00
分析
例子中
0.1
0.1 0.2
0.1 0.2 0.3
0.1 0.2 0.3 0.4
0.2
0.2 0.3
0.2 0.3 0.4
0.3
0.3 0.4
0.4
寻找规律
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<iomanip>
using namespace std;
double arr[100005];
int main(){
int n;
for (; scanf("%d", &n) != EOF;){
memset(arr, 0, sizeof(double)* 100005);
for (int i = 0; i < n; i++){
scanf("%lf", &arr[i]);
}
double sum = 0.0;
for (int i = 0; i < n; i++){
sum += (arr[i])*(n - i)*(i + 1);
}
cout << fixed << setprecision(2) << sum << endl;
}
return 0;
}