1104 Sun of Number Segments

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:
4
0.1 0.2 0.3 0.4
Sample Output:
5.00

分析

例子中

0.1 
0.1 0.2
0.1 0.2 0.3
0.1 0.2 0.3 0.4
    0.2
    0.2 0.3
    0.2 0.3 0.4
        0.3
        0.3 0.4
            0.4

寻找规律

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<iomanip>
using namespace std;
double arr[100005];
int main(){
  int n;
  for (; scanf("%d", &n) != EOF;){
    memset(arr, 0, sizeof(double)* 100005);
    for (int i = 0; i < n; i++){
      scanf("%lf", &arr[i]);
    }
    double sum = 0.0;
    for (int i = 0; i < n; i++){
      sum += (arr[i])*(n - i)*(i + 1);
    }
    cout << fixed << setprecision(2) << sum << endl;
  }
  return 0;
}   
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值