According to Wikipedia:
Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.
Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.
Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
Sample Output 2:
Merge Sort
1 2 3 8 4 5 7 9 0 6
解题思路:对输入的数组进行插入排序或者是归并排序,中间过程中对数据进行比较,如果与评判数组一致则记录下,下一次排序的结果,若到最终都不一致,则进行另一种排序方式。我是先进行归并排序,在中间过程中寻找是否一致,若没有找到,则进行插入排序。
做这道题的时候傻逼了,一看到归并排序直接上手就写,写了个二分的归并,看结果一直不对,才发现题目中的归并并不是二分的。
编号为2的测试点是个坑,是经过别人提醒才知道的,这道题的插入排序默认一个数字算是属于有序的序列,所以要从两个数字楷开始进行插入排序。
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<vector>
using namespace std;
vector<int> inVec(105);
vector<int> judgeVec(105);
vector<int> outArr(105);
int n= 0;
//type = 1 merger type = 2 insert
int type = 0;
bool isMerger(vector<int>tempVec){
int step = 2;
while (step <= n){
int flag = 0;
int begin = 0;
int end = step;
while (end < n){
sort(tempVec.begin() + begin, tempVec.begin() + end);
begin = end;
end += step;
}
sort(tempVec.begin() + begin, tempVec.begin() + n );
step *= 2;
if (type == 1){
for (int i = 0; i < n; i++){
outArr[i] = tempVec[i];
}
return true;
}
for (int i = 0; i < n; i++){
if (tempVec[i] != judgeVec[i]){
flag = 1;
break;
}
}
if (!flag){
type = 1;
}
}
return false;
}
void insert(vector<int>tempVec){
//两个数字开始
for (int i = 2; i <= n; i++){
int flag = 0;
sort(tempVec.begin(), tempVec.begin() + i);
if (type == 2){
for (int i = 0; i < n; i++){
outArr[i] = tempVec[i];
}
return;
}
for (int i = 0; i < n; i++){
if (tempVec[i] != judgeVec[i]){
flag = 1;
}
}
if (!flag){
type = 2;
}
}
}
int main(){
for (; scanf("%d", &n) != EOF;){
type = 0;
int temp[100] = { 0 };
for (int i = 0; i < n; i++){
scanf("%d", &inVec[i]);
}
for (int i = 0; i < n; i++){
scanf("%d", &judgeVec[i]);
}
vector<int>tempVec(inVec);
if (isMerger(tempVec)){
cout << "Merge Sort" << endl;
}
else{
cout << "Insertion Sort" << endl;
insert(tempVec);
}
cout << outArr[0];
for (int i = 1; i < n; i++){
cout << " " << outArr[i];
}
cout << endl;
}
return 0;
}