1056 Mice and Rice

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,…NP-1) where each Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,…NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5

解题思路:这道题的题意有点混乱,第一行输入的是老鼠的数量,和每次匹配的数量,第二行输入的是编号0——n-1号老鼠的重量,第三行输入的是进行比赛的老鼠的编号的排列顺序。样例输入中第三行是6 0 8 7 10 5 9 1 4 2 3,就是6号,0号,8号老鼠一组。7号,10号,5号老鼠一组……,这题意混乱了我好久。看懂题目之后就比较简单了,模拟淘汰的顺序就好,只是在淘汰的过程中需要对老鼠进行排名,在某一轮中淘汰的老鼠的rank就是这一轮中晋级的老鼠的数量+1.

#include<iostream>
#include<stdio.h>
#include<vector>
using namespace std;
int main(){
    for (int p, g; scanf("%d%d", &p, &g) != EOF;){
        int *mice = new int[p];
        int *rank = new int[p];
        for (int i = 0; i < p; i++){
            rank[i] = 1;
            scanf("%d", &mice[i]);
        }
        vector<int>compete;
        for (int i = 0; i < p; i++){
            int temp;
            scanf("%d", &temp);
            compete.push_back(temp);
        }
        while (compete.size() != 1){
            vector<int>next;
            int nextCount = compete.size() / g;
            if (compete.size() % g != 0){
                nextCount++;
            }
            for (int i = 0; i < compete.size(); i += g){
                int win = -1;
                int fatest = -1;
                for (int j = i; j < i+g && j < compete.size(); j++){
                    if (mice[compete[j]] > fatest){
                        win =compete[j];
                        fatest = mice[compete[j]];
                    }
                }
                if (win != -1){
                    next.push_back(win);
                    rank[win]--;
                }
                for (int j = i; j < i + g && j < compete.size(); j++){
                    if (compete[j] != win){
                        rank[compete[j]] = nextCount+1;
                    }
                }
            }
            compete = vector<int>(next);
        }
        rank[compete[0]] = 1;
        printf("%d", rank[0]);
        for (int i = 1; i < p; i++){
            printf(" %d", rank[i]);
        }
        printf("\n");
        delete[] mice;
        delete[] rank;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值