OJ:PAT A1048 Find Coins - 双下标归中

思想

问题:有一个函数 f ( i , j ) f(i,j) f(i,j)是基于一个数组定义的,需要遍历一个数组,寻找使 f ( i , j ) f(i,j) f(i,j)满足条件的 ( i , j ) (i,j) (i,j).

解决:在这种情况下,如果从 ( i ± 1 , j ) (i±1,j) (i±1,j) ( i , j ) (i,j) (i,j) ( i , j ± 1 ) (i,j±1) (i,j±1) ( i , j ) (i,j) (i,j) f ( i , j ) f(i,j) f(i,j)的值可以用某种方法维护,而且有单调性质:
可以设置头尾下标,从两端往中间移动,从而遍历到每个合法情况。

很多情况下,双下标其实也是通过排序降低时间复杂度的后置部分:排序过后的数组才能应用双下标。但是这种方法比较特殊,所以先单独拎出来。

题目:1048 Find Coins (25 分)

这道题几乎可以作为这类「双下标-归中」问题的模板题。

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​5​​, the total number of coins) and M (≤10​3​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V​1​​ and V​2​​ (separated by a space) such that V​1​​+V​2​​=M and V​1​​≤V​2​​. If such a solution is not unique, output the one with the smallest V​1​​. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

思路

典型的在数组中寻找数据对的问题,用双下标非常合适。首先对数组排序,然后一头一尾开始寻找符合要求的数对。

#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <cstdio>
#include <bitset>
using namespace std;

const int MAX = 100005;
const int INF = 0x3f3f3f3f;

int main(){
    // data & input
    int N, M;
    cin >> N >> M;
    int coin[MAX];
    for(int i=0; i<N; i++){
        scanf("%d", &coin[i]);
    }
    // main logic
    sort(coin, coin+N);
    int head = 0, tail = N-1;
    while(true){
        while(coin[head] + coin[tail] > M) tail--;
        if(head >= tail) break;
        if(coin[head] + coin[tail] == M){
            printf("%d %d", coin[head], coin[tail]);
            return 0;
        }
        head++;
    }
    // output
    printf("No Solution");
    return 0; 
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值