Number Sequence(KMP基础)

A - Number Sequence

Time Limit: 5000 MS Memory Limit: 32768 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status]

Description

Given two sequences of numbers : 
a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

#include<stdio.h>
using namespace std;

int n,m,slen,tlen;
int s[1000010];
int t[10010];
int next[10010];

void getnext()
{
    int j,k;
    j=0;
    k=-1;
    next[0]=-1;
    while(j<tlen)
    {
        if(k==-1 || t[j]==t[k])
        {
            next[++j] = ++k;
        }
        else
        {
            k = next[k];
        }
    }
}
///查找到模式串第一次出现的地方
int kmp_index()
{
    int i=0,j=0;
    getnext();

    while(i<slen && j<tlen)
    {
        if(j==-1 || s[i]==t[j] )
        {
            i++;
            j++;
        }
        else
        {
            j = next[j];
        }
    }
    if(j == tlen)
    {
        return i-tlen+1;
    }
    else
    {
        return -1;
    }
}

int main()
{
    int m;
    scanf("%d",&m);
    while(m--)
    {
        scanf("%d%d",&slen,&tlen);
        for(int i=0; i<slen; i++)
        {
            scanf("%d",&s[i]);
        }
        for(int j=0; j<tlen; j++)
        {
            scanf("%d",&t[j]);
        }
        int q = kmp_index();
        printf("%d\n",q);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值