Number Sequence (KMP)

Number Sequence


Given two sequences of numbers : a[1], a[2], …… , a[N], and b[1], b[2], …… , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], …… , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
给定两个数字序列:一个[1],一个[2],…, a[N], b[1], b[2],…, b[M] (1 <= M <= 10000, 1 <= N <= 1000000)。你的任务是找到一个使a[K] = b[1], a[K + 1] = b[2],…, a[K + M - 1] = b[M]。如果存在多个K,则输出最小的K。


Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], …… , a[N]. The third line contains M integers which indicate b[1], b[2], …… , b[M]. All integers are in the range of [-1000000, 1000000].
输入的第一行是数字T,它表示案例的数量。每个案例包含三行。第一行是两个数字N和M (1 <= M <= 10000, 1 <= N <= 1000000)。第二行包含N个整数,表示一个[1],一个[2],…[N]。第三行包含M个整数,表示b[1], b[2],…,b[M]。所有整数都在[-1000000,1000000]的范围内。


Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
对于每个测试用例,您应该输出一行,其中只包含上面描述的K。如果不存在这样的K,则输出-1


Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1


Sample Output
6
-1


#include<stdio.h>
#include<algorithm>
const int maxn= 1000010;
int t[maxn];    //子串 
int s[maxn];    //母串
int next[maxn];
int n,m;
void getnext(){
    int j=0;
    int i=1;
    next[0]=0;
    while(i<m){
        if(t[i]==t[j]){
            next[i++]=++j;
        } 
        else if(!j){
            i++;
        }
        else{
            j=next[j-1];
        }
    }
}
int kmp(){
    int i=0;
    int j=0;
    while(i<n&&j<m)
    {
        if(s[i]==t[j]){
            i++;
            j++;
        } 
        else if(!j){
            i++;
        }
        else{
            j=next[j-1];
        }
    } 
    if(j==m)  return i-m+1;
    else return -1;
}
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            scanf("%d",&s[i]);
        for(int i=0;i<m;i++)
            scanf("%d",&t[i]);
        getnext();
        printf("%d\n",kmp());
    }
    return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值