Eddy's research II

As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate.

Ackermann function can be defined recursively as follows:


Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).
Input Each line of the input will have two integers, namely m, n, where 0 < m < =3.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24.
Input is terminated by end of file.
Output For each value of m,n, print out the value of A(m,n).
Sample Input
1 3
2 4
Sample Output
5
11

题目大意:用题中给的方程组求输入的数(m<=3).
思路:直接递推会超时,所以就找规律,分为四种情况,m=1,m=2,m=3,m=4.

ac代码: //不知道为什么把函数部分放在主函数内会超时,这样写秒过
#include<stdio.h>
#include<string.h>
const int maxn=100009;
int dp[4][maxn];
void gm(){
 for(int i=0;i<=maxn;i++){  \\规律就是这个
  dp[0][i]=i+1;
  dp[1][i]=i+2;
  dp[2][i]=2*i+3;}
 dp[3][0]=5;
 for(int i=1;i<=24;i++)
 dp[3][i]=2*dp[3][i-1]+3;
}
int main(){
 gm();
 int m,n;
 while(scanf("%d%d",&m,&n)!=EOF){
 printf("%d\n",dp[m][n]);
 }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值