HDU-1165-Eddy's research II(递推 打表 找规律)

Eddy’s research II

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4686 Accepted Submission(s): 1709

Problem Description
As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate.

Ackermann function can be defined recursively as follows:

这里写图片描述
Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).

Input
Each line of the input will have two integers, namely m, n, where 0 < m < =3.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24.
Input is terminated by end of file.

Output
For each value of m,n, print out the value of A(m,n).

Sample Input
1 3
2 4

Sample Output
5
11

题意:根据给出的公式,求出对应的A(M,N)
注意M=1||2时,N<=100w
M==3时,N<=24

根据公式深搜打个表,递推公式就出来了
打表代码

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
int DFS(int m,int n)
{
    if(m==0)
        return n+1;
    if(m>0&&n==0)
        return DFS(m-1,1);
    return DFS(m-1,DFS(m,n-1));
}
int main()
{
    int m,n;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        printf("%d\n",DFS(m,n));
    }
    return 0;
}

最终代码

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
int DP[4][1000005];
int main()
{
    DP[1][0]=2;
    DP[2][0]=3;
    DP[3][0]=5;
    for(int i=1;i<=2;i++)
        for(int j=1;j<=1000000;j++)
            DP[i][j]=DP[i][j-1]+i;
    for(int j=1;j<=24;j++)
        DP[3][j]=DP[3][j-1]*2+3;
    int m,n;
    while(scanf("%d%d",&m,&n)!=EOF)
        printf("%d\n",DP[m][n]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值