hdoj1165

Eddy's research II

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2021    Accepted Submission(s): 734


Problem Description
As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate.

Ackermann function can be defined recursively as follows:


Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).
 

Input
Each line of the input will have two integers, namely m, n, where 0 < m < =3.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24. 
Input is terminated by end of file.
 

Output
For each value of m,n, print out the value of A(m,n).
 

Sample Input
  
  
1 3 2 4
 

Sample Output
  
  
5 11
 

Author
eddy
 

Recommend
JGShining

当m=1时:
A(1,n)   = A(0,A(1,n-1)) = A(1,n-1)+1 
             = A(0,A(1,n-2))+1 = A(1,n-2)+2.....
             = A(1,n-n)+n = A(0,1)+n=n+2;
当m=2时:
A(2,n) = A(1,A(2,n-1)) = A(2,n-1)+2
            = A(1,A(2,n-2))+2=A(2,n-2)+2*2...
            = A(2,n-n)+2*n = 2*n+3;
当m=3时:
A(3,n) = A(2,A(3,n-1)) = 2*(A(3,n-1)+3;

#include<iostream>
using namespace std;

long Ackermann(long m, long n) {
    if (n == 0)
        return Ackermann(m - 1, 1);
    else if (m == 2)
        return 2 * n + 3;
    else
        return 2 * Ackermann(m, n - 1) + 3;
}

int main() {
    long n, m;
    while (scanf("%ld %ld", &m, &n) != EOF) {
        if (m == 1)
            printf("%ld\n", n + 2);
        else if (m == 2)
            printf("%ld\n", 2 * n + 3);
        else if (m == 3)
            printf("%ld\n", Ackermann(m, n));

    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值