继续畅通工程

Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。

当N为0时输入结束。

Output
每个测试用例的输出占一行,输出全省畅通需要的最低成本。

Sample Input
3
1 2 1 0
1 3 2 0
2 3 4 0
3
1 2 1 0
1 3 2 0
2 3 4 1
3
1 2 1 0
1 3 2 1
2 3 4 1
0

Sample Output
3
1
0

Author
ZJU

Source
浙大计算机研究生复试上机考试-2008年

Recommend
We have carefully selected several similar problems for you: 1102 1856 1874 1272 1301

Statistic | Submit | Discuss | Note
Home | Top Hangzhou Dianzi University Online Judge 3.0
Copyright © 2005-2018 HDU ACM Team. All Rights Reserved.
Designer & Developer : Wang Rongtao LinLe GaoJie GanLu
Total 0.000000(s) query 6, Server time : 2018-04-05 12:09:17, Gzip enabled Administration

#include<cstdio>
#include<algorithm>
using namespace std;
int f[105];
int n;
struct node
{
    int vil_o, vil_t, way_cost, way_f;
}a[5005];//定义结构体 
int find(int x)
{
    if (x != f[x])
        f[x] = find(f[x]);
    return f[x];
}
bool join (int x, int y)
{
    int fx = find(x);
    int fy = find(y);
    if (fx == fy)
        return 0;
    f[fx] = fy;
    return 1;
}
int cmp(node a, node b)
{
    return a.way_cost < b.way_cost;
}//成本按升序排列 
void itoa()
{
    for (int i = 1; i <= n; i ++)
        f[i] = i;
}//初始化 
int main()
{
    while (~scanf ("%d", &n) && n)
    {
        int ans = n * (n - 1) / 2;
        for (int i = 0; i < ans; i ++)
        {
            scanf ("%d %d %d %d", &a[i].vil_o, &a[i].vil_t, &a[i].way_cost, &a[i].way_f);
            if (a[i].way_f == 1)
            {
                a[i].way_cost = 0;
                f[a[i].vil_o] = a[i].vil_t;//当道路修通时,规定一节点为另一节点的父亲
            } //如果路的状态已修建则该段路成本为零 
        }
        sort(a, a + ans, cmp);//这里错了好多次,就是ans写成了n,太粗心了
        itoa();
        int sum = 0;
        for (int i = 0; i < ans; i ++)
        {
            if (join (a[i].vil_o, a[i].vil_t))
                sum += a[i].way_cost;
        }
        printf("%d\n", sum);
    }
    return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值