Let x and y be two strings over some finite alphabet A. We would like to transform xinto y allowing only operations given below:
- Deletion: a letter in x is missing in y at a corresponding position.
- Insertion: a letter in y is missing in x at a corresponding position.
- Change: letters at corresponding positions are distinct
Certainly, we would like to minimize the number of all possible operations.
Illustration
A G T A A G T * A G G C | | | | | | | A G T * C * T G A C G C
Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct
This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like
A G T A A G T A G G C
| | | | | | |
A G T C T G * A C G C
and 4 moves would be required (3 changes and 1 deletion).
In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.
Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.
Write a program that would minimize the number of possible operations to transform any string x into a string y.
Input
The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.
Output
An integer representing the minimum number of possible operations to transform any string x into a string y.
Sample Input
10 AGTCTGACGC
11 AGTAAGTAGGC
Sample Output
4
/*
这道题不知道是题目的bug还是数据太水
只要用长序列的长度减去最长公共子序列就可以过,但是如果是abcd和ebecd实际是3但是这种方法算下来是2
但既然题目可以a也无所谓这些,只不过刚开始一直以为这种方法是错的,有点方
ans = n - dp[m][n];
dp[m][n] : 最长公共子序列长度
*/
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<queue>
#include<vector>
using namespace std;
const int MX = 1005;
int dp[MX][MX];
char s1[MX], s2[MX];
int n, m, tot;
int solve()
{
for(int i = 0; i < m; i++)
{
for(int j = 0; j < n; j++)
{
if(s1[i] == s2[j]){
dp[i + 1][j + 1] = dp[i][j] + 1;
}
else{
dp[i + 1][j + 1] = max(dp[i][j + 1], dp[i + 1][j]);
}
}
}
return dp[m][n];
}
int main()
{
while(scanf("%d", &m) != EOF)
{
scanf("%s", s1);
scanf("%d %s", &n, s2);
int num = solve();
cout<<n - num<<endl;
}
return 0;
}