POJ - 3356 AGTC 区间dp

5 篇文章 0 订阅

Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

Deletion: a letter in x is missing in y at a corresponding position.
Insertion: a letter in y is missing in x at a corresponding position.
Change: letters at corresponding positions are distinct
Certainly, we would like to minimize the number of all possible operations.

Illustration
A G T A A G T * A G G C

| | | | | | |

A G T * C * T G A C G C
Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct
This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A G T A A G T A G G C

| | | | | | |

A G T C T G * A C G C
and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC

Sample Output

4

题意:
给出字符串s1。s2。
求出将s1通过下列三种操作:
1.插入一个字符
2.删除一个字符
3.改变一个字符
变换成字符s2所需要的最小操作次数。

题解:
定义dp[i][j]表示将s1的前i个和s2的前j个进行匹配所需的最小值。
可以将s1的第i个删掉,即dp[i-1][j]+1
或者将s2的第j个删掉,即dp[i][j-1]+1
或者将s1的第i个和s2的第j个进行匹配,根据它们是否相同来判断dp[i-1][j-1]是否+1
【依旧只是对拍了而已。
update:10.29 代码没问题,但是poj很坑的是多组数据。。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int N = 1000 + 10;

int n1,n2;
int dp[N][N];
char s1[N],s2[N];

int main(){
    while(~scanf("%d%s",&n1,s1+1)){
        scanf("%d%s",&n2,s2+1);
        memset(dp,63,sizeof(dp));
        for(int i=0;i<=max(n1,n2);++i) dp[i][0]=dp[0][i]=i;
        for(int i=1;i<=n1;++i){
            for(int j=1;j<=n2;++j){
                dp[i][j]=min(dp[i][j-1]+1,dp[i-1][j]+1);
                dp[i][j]=min(dp[i][j],dp[i-1][j-1]+(s1[i]!=s2[j]));
            }
        }
        printf("%d\n",dp[n1][n2]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值