POJ 3311 Hie with the Pie

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8
解题思路:首先由于每个点可以经过多次,我们要使最终经过的路径长度最短,因此我们首先应该预处理出任意两点之间的最短路径,接下来便是每个节点经过一次且仅一次遍历完所有的节点需要经过的最短路径,便是经典的TSP问题.
TSP问题的状态转移方程为dp[i][j]为当前经过的节点集合且最后经过的点为j时的最短路径,复杂度为O(n^2logn)
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <utility>
#include <algorithm>
#include <functional>
using namespace std;
const int maxn = 12;
const int inf  = 0x3f3f3f3f;
int dis[maxn][maxn];
int dp[1<<12][maxn];
int n;

void floyd() {
    for(int k = 0; k < n; ++k) {
        for(int i = 0; i < n; ++i) {
            for(int j = 0; j < n; ++j) {
                if(i == j) continue;
                dis[i][j] = min(dis[i][j], dis[i][k] + dis[k][j]);
            }
        }
    }
}

void solve() {
    memset(dp, inf, sizeof(dp));
    for(int i = 0; i < n; ++i) {
        dp[1<<i][i] = dis[0][i];
    }
    for(int i = 1; i < (1<<n); ++i) {
        for(int j = 0; j < n; ++j) {
            if(!(i&(1<<j))) continue;
            for(int k = 0; k < n; ++k) {
                if(((1<<k)&i) && k != j && dp[i^(1<<j)][k] != inf) {
                    dp[i][j] = min(dp[i][j], dp[i^(1<<j)][k] + dis[k][j]);
                }
            }
        }
    }
}

int main() {

    //freopen("aa.in", "r", stdin);

    while(scanf("%d", &n) != EOF) {
        if(n == 0) break;
        n++;
        for(int i = 0; i < n; ++i) {
            for(int j = 0; j < n; ++j) {
                scanf("%d", &dis[i][j]);
            }
        }
        floyd();
        solve();
        int ans = inf;
        for(int i = 0; i < n; ++i) {
            ans = min(ans, dp[(1<<n)-1][i] + dis[i][0]);
        }
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值