Safecracker-深搜-dfs

题目总览:

=== Op tech briefing, 2002/11/02 06:42 CST ===
“The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein’s secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, …, Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary.”

v - w^2 + x^3 - y^4 + z^5 = target

“For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn’t exist then.”

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

“Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or ‘no solution’ if there is no correct combination. Use the exact format shown below.”

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

Sample Output

LKEBA
YOXUZ
GHOST
no solution

题目大意:

大写字母A B C…Z依次代表1 2 3…26,
给定一个target,给定一个字符串,从中依次选取5个字母x1,x2,x3,x4,x5,其代表的数值使下面的公式成立:
x1- x2^2 + x3 ^ 3 - x4 ^ 4 + x5 ^ 5 = target
重点条件:
if there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary

  • eg:
    For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1
- 输入:

每行输入一个数字和一串大写字母,

- 输出:

输出最后一组符合上述条件的五个大写字母.

解决思路:

将输入的大写字母从大到小排序,然后在此基础上深搜

解题代码:

#include<bits/stdc++.h>

using namespace std;
int target;
char code[13];
bool used[13];
int tag[6];
int len;

int cmp(char a, char b){
	return a > b;
}

int pow(int num, int n){
	int re = 1;
	for(int i = 0; i < n; i++)
		re*=num;
	return re;
} 

bool is_equal(){
	int sum = tag[0];
	for(int i = 1; i < 5; i++){
		if(i%2==0)
		sum+=pow(tag[i], i+1);
		else
		sum-=pow(tag[i], i+1);
	}
	return sum == target;
}

bool dfs(int count){
	if(count == 5 ){
		if(is_equal())
		return true;
		return false;
	}
	for(int i = 0; i < len; i++){
		if(!used[i]){
			used[i] = 1;
			tag[count] = code[i]-'A'+1;
			if(dfs(count+1))
			return true;
			used[i] = 0;
		}
	}
	return false;
}
 
int main()
{
	while(cin>>target>>code){
		if(!target && !strcmp(code, "END")){
			return 0;
		}
		len = strlen(code);
		sort(code, code + len, cmp);
		memset(used, 0, sizeof(used));
		if(dfs(0)){
			for(int i = 0; i < 5; i++){
				printf("%c", tag[i]+'A'-1);
			}
			cout<<endl;
		}else{
			cout<<"no solution"<<endl;
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值