IDEA报错:Error: java: 错误:不支持发行版本5

在IDEA做maven项目时总会遇到错误:Error: java: 错误: 不支持发行版本5,这是因为在IDEA的java编译器默认版本太低了,有两种方法可以更正:

第一种:

打开设置
​​​​​​

打开Java Compiler

 此处选择高于10的版本即可

但是第一种办法在再次修改pom.xml时,他还是会自动变更为1.5版本

第二种方法:

在pom.xml中引入指定maven-compiler-plugin的版本,此项设置会同时影响LanguageLevel和JavaCompiler,在修改之后会默认使用此处的版本

<build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <version>3.8.1</version>
            <configuration>
                <!--source 和 target根据个人需要自己修改-->
                <source>11</source>
                <target>11</target>
            </configuration>
        </plugin>
    </plugins>
</build>

  • 17
    点赞
  • 51
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Hhzzy99

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值