POJ-2392 Space Elevator

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

题目大意:有个牛跑到太空用石头垒,给出每种石头的高度,以及最高可以到达的高度,还有这种石头的个数。

思路:对石头所能到达的高度从小到大进行排序,先选用所到高度小的,本是一个多重背包问题,可我写的代码却没有体现到。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    int l;
    int h;
    int s;
} q[410];
int book[40010],num[40010];
bool cmp(node u,node v)
{
    return u.h<v.h;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {

        for(int i=0; i<n; i++)
            scanf("%d%d%d",&q[i].l,&q[i].h,&q[i].s);
        sort(q,q+n,cmp);
        memset(book,0,sizeof(book));
        book[0]=1;
        int ans=0;
        for(int i=0; i<n; i++)
        {
            memset(num,0,sizeof(num));
            for(int j=q[i].l; j<=q[i].h; j++)
            {
                if(!book[j]&&book[j-q[i].l]&&num[j-q[i].l]<q[i].s)
                {
                    book[j]=1;
                    num[j]=num[j-q[i].l]+1;//num数组记录到达该高度所用该石头的个数
                    ans=max(ans,j);
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

别人的多重背包:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    int l;
    int h;
    int s;
} q[410];
int dp[40010];
bool cmp(node u,node v)
{
    return u.h<v.h;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {

        for(int i=0; i<n; i++)
            scanf("%d%d%d",&q[i].l,&q[i].h,&q[i].s);
        sort(q,q+n,cmp);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            for(int k=1;k<=q[i].s;k++)
            {
                for(int j=q[i].h;j>=q[i].l;j--)
                {
                    dp[j]=max(dp[j],dp[j-q[i].l]+q[i].l);
                }
            }
        }
        int ans=0;
        for(int i=0;i<=q[n-1].h;i++)
        {
            ans=max(ans,dp[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值