HDU-1506 Largest Rectangle in a Histogram

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 
 
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

题目大意:每个小矩形的宽度为1,高度不等,让你输出最大的矩形面积。

参考链接:https://blog.csdn.net/u012773338/article/details/40265223

思路:从每一个矩形开始遍历,记录每一个矩形所能到达的最左和最右的边界,然后遍历一遍,求出最大值。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
long long f[100010],l[100010],r[100010];
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        memset(f,0,sizeof(f));
        memset(l,0,sizeof(l));
        memset(r,0,sizeof(r));
        long long ans=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&f[i]);
            l[i]=r[i]=i;//初始化
        }
        f[0]=f[n+1]=-1;//两个边界
        for(int i=1;i<=n;i++)
        {//左边
            while(f[i]<=f[l[i]-1])
                l[i]=l[l[i]-1];
        }
        for(int i=n;i>=1;i--)
        {//右边
            while(f[i]<=f[r[i]+1])
                r[i]=r[r[i]+1];
        }
        for(int i=1;i<=n;i++)
        {
            if(f[i]*(r[i]-l[i]+1)>ans)
                ans=f[i]*(r[i]-l[i]+1);//高*宽
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值