Largest Rectangle in a Histogram (连续矩形 够成矩形的最大面积 dp)

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

 
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

题意:给了 n 个连续矩形的高度,规定每个矩形的宽为 1 ,求连续矩形组成的矩形的最大面积。

思路:我们可以求出每个矩形向左,向右连续比它自身高的宽度,记下标为(l,r)。因此我们就得到了大于等于这个矩形高度的最大的宽度,即可求出以这个矩形为高度的最大面积,维护最大面积即可。

代码如下:

#include<cstdio>
#include<cstring>
#define N 100010
long long num[N];
int l[N],r[N];
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=1;i<=n;i++)
            scanf("%lld",&num[i]);
        l[1]=1,r[n]=n;//第一个的矩形的左端为1,第n个矩形的右端为n
        for(int i=2;i<=n;i++)
        {
            int t=i;
            while(t>1&&num[t-1]>=num[i]) //取num[i]的左边比它本身大的连续区间的最左端下标,用l[i]记录
                t=l[t-1];
            l[i]=t; //记录 i矩形的最左端
        }
        for(int i=n-1;i>=1;i--)
        {
            int t=i;
            while(t<n&&num[t+1]>=num[i]) //取num[i]的右边比它本身大的连续区间的最右端下标,用r[i]记录
                t=r[t+1];
            r[i]=t;   //记录 i矩形的最右端
        }
        long long maxx=0;
        for(int i=1;i<=n;i++)
        {
            long long s=(r[i]-l[i]+1)*num[i];  //两端之差为矩形的宽度
            if(s>maxx)      //维护最大值
                maxx=s;
        }
        printf("%lld\n",maxx);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值