1005. Spell It Right (20)-PAT甲级真题

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345

Sample Output:
one five

———————————————————————————————————————————————
一开始并没有想到用字符串解决:

#include <iostream>
#include<string>
using namespace std;
int main() {
	int num,sum=0;
	cin>>num;
	//将这个数的各个位上的数求和 
	while(num){
		sum+=num%10;
		num/=10;
	}
	string arr[10] = {"zero","one","two","three","four","five","six","seven","eight","nine"};
	int arr1[110];
	int count=0;
	//将和sum的各个位上的数存入数组 
	while(sum){
		arr1[count++]=sum%10;
		sum/=10;
	}

	for(int i=count-1;i>=0;i--){
		if(i!=0)
			cout<<arr[arr1[i]]<<" ";
		else cout<<arr[arr1[i]];
	}
	getchar();
	getchar();
	return 0;
}

但是在测试时有很多测试点无法通过
在这里插入图片描述
后来发现是数据的取值范围的问题,题目要求的数边界太大了,用int根本无法存下。
于是想到用字符串解决:

#include<string>
using namespace std;
int main() {
	string a;
	cin >> a;
	int sum = 0;
	//得到这个数的各个位上的数,并将这些数求和
	for (int i = 0; i<a.length(); i++)
		sum += (a[i] - '0');
	//将sum转为字符串
	string s = to_string(static_cast<long long>(sum));
	string arr[10] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
	//先输出一位
	cout << arr[s[0] - '0'];		//s[0] - '0'将字符转换成相应的数值
	//后面的输出以空格加字符串形式输出,满足题目要求最后无空格的要求
	for (int i = 1; i < s.length(); i++)
	cout << " " << arr[s[1] - '0'];

	getchar();
	getchar();
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值