PAT甲级——Digital Library

 

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

思路: 本题给出N本书的编号、书名、作者、关键词、出版社以及出版年份,然后根据某个除编号以外的信息来查询所有满足该信息的书的编号,并且要求编号从小到大输出。这个可以用map<string,set<int>>处理,即分别建立书名、作者、关键词、出版社以及出版社年份与编号的map映射。这里读入数据的时候要十分注意,特别是读入关键词的时候,可以仔细看看那部分代码。

注意点:

  • 如果单独把查询操作提炼成一个函数,那么一定要对参数使用引用,否则最后一组数据会超时。由此可见,字符串以及map的参数传递速度较慢,如果要作为函数的参数的话,需要尽可能加上引用。
  • 在scanf或者cin出入书的编号Id后,必须用getchar接收掉后面的空格,否则getline会将换行读入。

代码:

#include <iostream>
#include<map>
#include<set>
#include<string>
using namespace std;

map<string, set<int>>mpTitle, mpAuthor, mpKey, mpPub, mpYear;
void query(map<string, set<int> >&mp, string &str)
{
	if (mp.find(str) == mp.end()) printf("Not Found\n");
	else {
		for (set<int>::iterator it = mp[str].begin(); it != mp[str].end(); it++)
		{
			printf("%07d\n", *it);
		}
	}
}
int main()
{
	int n, m, id, type;
	string title, author, key, pub, year;
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%d", &id);
		char c = getchar();
		getline(cin, title);
		mpTitle[title].insert(id);
		getline(cin, author);
		mpAuthor[author].insert(id);
		while (cin>>key)
		{
			mpKey[key].insert(id);
			c = getchar();
			if (c == '\n') break;
		}
		getline(cin, pub);
		mpPub[pub].insert(id);
		getline(cin, year);
		mpYear[year].insert(id);
	}
	string temp;
	scanf("%d", &m);
	for (int i = 0; i < m; i++)
	{
		scanf("%d: ", &type);
		getline(cin, temp);
		cout << type << ": " << temp << endl;
		if (type == 1) query(mpTitle, temp);
		else if (type == 2) query(mpAuthor, temp);
		else if (type == 3) query(mpKey, temp);
		else if (type == 4) query(mpPub, temp);
		else query(mpYear, temp);

	}
	return 0;
}


复习:

        这道题关键是要能想到建立map<string,set<int>>这样一个映射,因为查询的时候要输出对应信息的全部书籍编号,那么就要把每个信息和该信息包含的所有书的编号联系起来,而且set里面会自动对书的名字进行排序。

 

二刷代码:

#include <iostream>
#include<map>
#include<string>
#include<set>
using namespace std;


map<string, set<int>> mpTitle, mpAuthor, mpKey, mpPub, mpYear;

void query(map<string, set<int>>& mp, string& str)//在map中查找str
{
	if (mp.find(str) == mp.end()) printf("Not Found\n");//map中的find(key)函数,返回键为key的映射的迭代器
	else
	{
		for (set<int>::iterator it = mp[str].begin(); it != mp[str].end(); it++)
			printf("%07d\n", *it);
	}

}

int main()
{
	int n, m, id, type;
	string title, author, key, pub, year;
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%d", &id);
		char c = getchar();//接收换行符
		getline(cin, title);
		mpTitle[title].insert(id);
		getline(cin, author);
		mpAuthor[author].insert(id);
		while (cin>>key)
		{
			mpKey[key].insert(id);
			c = getchar();
			if (c == '\n') break;
		}
		getline(cin, pub);
		mpPub[pub].insert(id);
		getline(cin, year);
		mpYear[year].insert(id);


	}

	string temp;
	scanf("%d", &m);
	for (int i = 0; i < m; i++)
	{
		scanf("%d: ", &type);
		getline(cin, temp);
		cout << type << ": " << temp << endl;
		if (type == 1) query(mpTitle, temp);
		else if (type == 2) query(mpAuthor, temp);
		else if (type == 3) query(mpKey, temp);
		else if (type == 4) query(mpPub, temp);
		else query(mpYear, temp);

	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值