【PAT甲级A1022】Digital Library (30分)(c++)

1022 Digital Library (30分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤104 ) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;
Line #2: the book title – a string of no more than 80 characters;
Line #3: the author – a string of no more than 80 characters;
Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
Line #5: the publisher – a string of no more than 80 characters;
Line #6: the published year – a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

1: a book title
2: name of an author
3: a key word
4: name of a publisher
5: a 4-digit number representing the year
Output Specification:
For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题意:

给出n本书的编号、书名、作者、关键词、出版社、出版时间,当查询这6个指标中的一个时,按顺序输出相关书籍的编号。

思路:

用map映射,由于不需要键值的排序,可采用unordered_map大大减小运行时间,对6个指标分别映射。读取书名的时候用getline记录有空格的字符串,读取关键词的时候用while(cin>>words)来记录字符串,用getchar()来吸收中间的空格,直到吸收字符串为换行符为止。(注意点:id若用int存储,输出是要记得补零)

参考代码:

#include <cstdio>
#include <string>
#include <iostream>
#include <vector>
#include <unordered_map>
#include <algorithm>
using namespace std;
int main() {
    vector<unordered_map<string,vector<int>>> mp(6);
    int n,m,id,index;
    string title,author,words,publisher,year,search;
    scanf("%d",&n);
    while(n--){
        scanf("%d",&id);getchar();
        getline(cin,title);
        mp[1][title].push_back(id);
        getline(cin,author);
        mp[2][author].push_back(id);
        while(cin>>words){
            mp[3][words].push_back(id);
            char c=getchar();
            if(c=='\n')break;
        }
        getline(cin,publisher);
        mp[4][publisher].push_back(id);
        getline(cin,year);
        mp[5][year].push_back(id);
    }
    scanf("%d",&m);
    for(int i=0;i<m;i++){
        scanf("%d: ",&index);
        getline(cin,search);
        cout<<index<<": "<<search<<endl;
        if(mp[index].count(search)){
            sort(mp[index][search].begin(),mp[index][search].end());
            for(int j=0;j<mp[index][search].size();j++)
                printf("%07d\n",mp[index][search][j]);
        }else cout<<"Not Found"<<endl;
    }
    return 0;
}

如有错误,欢迎指正

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值