HDU 1083 (匈牙利算法)

Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:
有P个学生共选择了P门课程(每个学生选择一门课程)
every student in the committee represents a different course (a student can represent a course if he/she visits that course)*
每个学生可以选择不同的课程
each course has a representative in the committee***
每门课程都有一个学生选
Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 … Student1 Count1
Count2 Student2 1 Student2 2 … Student2 Count2

CountP StudentP 1 StudentP 2 … StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you’ll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line “YES” if it is possible to form a committee and “NO” otherwise. There should not be any leading blanks at the start of the line.
Sample Input
2 (2组数据)
3 3 (3门课程,3个学生)
3 1 2 3 (课程1有3个学生想选.分别是学生1,学生2,学生3)
2 1 2 (课程2有2个学生想选,分别是学生1,学生2)
1 1 (课程3有1个学生想选,是学生1)
3 3
2 1 3
2 1 3
1 1

Sample Output
YES
NO
利用匈牙利算法找到最大匹配.如果最大匹配数等于课程数P输出YES,否则输出NO.

HDU1083 AC代码:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int line[520][520],used[520],stu[520];
int p,n;
int Find(int x)
{
	int i;
	for(i=1;i<=n;i++)
	{
		if(line[x][i]==1&&used[i]==0)
		{
			used[i]=1;
			if(stu[i]==0||Find(stu[i]))
			{stu[i]=x; return 1; }
		}
	}
	return 0;
}
int main ()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		memset(line,0,sizeof(line)); 
		memset(stu,0,sizeof(stu)); 
		int sum,i,j,m,stud;
		scanf("%d %d",&p,&n);
		for(i=1;i<=p;i++)
		{
			scanf("%d",&m);
			for(j=1;j<=m;j++)  {
				scanf("%d",&stud);
				line[i][stud]=1;//课程去配对学生
			}
	   }
		sum=0;
		for(i=1;i<=p;i++)
		{
			memset(used,0,sizeof(used)); 
			if(Find(i))  sum+=1;
		}
		if(sum==p)  printf("YES\n");
		else        printf("NO\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值