HDU-1179 匈牙利算法

Input
There are several cases. For each case, there is two integers N and M in the first line,which mean there is N wizards and M wands(0 < N <= M <= 100).
Then M lines contain the choices of each wand.The first integer in i+1th line is Ki,and after these there are Ki integers Bi,j which are the wizards who fit that wand. (0<=Ki<=N,1<=Bi,j<=N)
Output
Only one integer,shows how many wands Ollivander can sell.
Sample Input
3 4
3 1 2 3
1 1
1 1
0
Sample Output
2
Hint
Wand 1 fits everyone, Wand 2,3 only fit the first wizard,and Wand 4 does not fit anyone. So Ollivanders can sell two wands:
sell Wand 1 to Wizard 2 and Wand 2 to Wizard 1,or sell Wand 1 to Wizard 3 and Wand 3 to Wizard 1 ,or some other cases. But
he cannot sell 3 wands because no 3 wands just fit 3 wizards.
代码:

#include<bits/stdc++.h>
#define maxn 103
using namespace std;
inline int read(){
	int x=0,f=1;char ch=getchar();
	while(ch>'9'||ch<'0'){if(ch=='-')f=-1;ch=getchar();}
	while(ch>='0'&&ch<='9'){x=(x<<3)+(x<<1)+ch-'0';ch=getchar();}
	return x*f;
}
int n,m,line[maxn][maxn],used[maxn],nxt[maxn];
int Find(int x){
	for(int i=1;i<=m;++i)
		if(line[x][i]&&!used[i]){
			used[i]=1;
			if(nxt[i]==0||Find(nxt[i])){
				nxt[i]=x;
				return 1;
			}
		}
	return 0;
}
int match(){
	int sum=0;
	for(int i=1;i<=n;++i){
		memset(used,0,sizeof(used));
		if(Find(i))++sum;
	}
	return sum;
}
int main(){
	while(~scanf("%d%d",&n,&m)){
		memset(line,0,sizeof(line));
		memset(nxt,0,sizeof(nxt));
		for(int i=1;i<=m;++i){
			int u=read();
			while(u--)line[read()][i]=1;
		}
		printf("%d\n",match());
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值