PTA 题解:Tree Traversals Again

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

代码实现:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct Tnode* tree;
struct Tnode
{
    int data;
    tree left;
    tree right;
};

tree createTnode(int d)
{
    tree newnode=(tree)malloc(sizeof(struct Tnode));
    newnode->left=NULL;
    newnode->right=NULL;
    newnode->data=d;
    return newnode;
}

tree createTree(int N);
void Traversal(tree T);

int main()
{
    int N;
    scanf("%d",&N);
    tree root=createTree(N);

    Traversal(root);
    return 0;
}
tree createTree(int N)
{
    char seq[10];
    int push=0,top=-1,pop=0;
    tree stack[N];
    struct Tnode* root=NULL;
    struct Tnode* current=NULL;
    int flag=0;
    getchar();//至关重要
    while(push<N||pop<N)
    {
        gets(seq);
        if(seq[1]=='u')
        {
            int l=strlen(seq);
            int d=seq[5]-'0';;
            if(l==7)
            {//d有可能是两位数
                d*=10;
                d+=seq[6]-'0';
            }
            tree newnode=createTnode(d);
            if(root==NULL)
            {
                root=newnode;
                current=root;
                stack[++top]=root;
            }
            else
            {
                if(current->left==NULL)
                {
                    current->left=newnode;
                }
                else
                {
                    current->right=newnode;
                }
                current=newnode;
                stack[++top]=current;//入栈
            }
            push++;
        }
        else
        {
            current=stack[top];
            //printf("%d\n",current->data);
            top--;//出栈
            pop++;
        }
    }//while
    return root;
}
int Flag=0;
void Traversal(tree T)
{
    if(T==NULL)return;
    Traversal(T->left);
    Traversal(T->right);
    if(Flag==1)printf(" ");
    else Flag=1;
    printf("%d",T->data);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值