CardTrick

题目描述

The magician shuffles a smallpack of cards, holds it face down and performs the following procedure:

  1. The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
  2. Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
  3. Three cards are moved one at a time…
  4. This goes on until the nth and last card turns out to be the n of Spades.

This impressive trick works ifthe magician knows how to arrange the cards beforehand (and knows how to give afalse shuffle). Your program has to determine the initial order of the cardsfor a given number of cards, 1 ≤ n ≤ 13.

输入

On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case consists of one line containing the integer n. 1 ≤ n ≤ 13

输出

For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…

样例输入

2
4
5

样例输出

2 1 4 3
3 1 4 5 2

AC代码:

#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
int main()
{
	int K,n;
	int i,j,k;
	int a[15],b[15];
	while(cin>>K)
	while(K--){
		cin>>n;
		queue<int>qt;
		for(i=1;i<=n;i++)
		qt.push(i);
		for(i=1;i<=n;i++){
			j=i;
			while(j--){
				k=qt.front();
				qt.pop();
				qt.push(k);
			}
			a[i]=qt.front();
			qt.pop();
		}
		for(i=1;i<=n;i++)
		b[a[i]]=i;
		for(i=1;i<n;i++)
		cout<<b[i]<<" ";
		cout<<b[i]<<endl;
	}
	return 0;
} 






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值