【HDU 5984】Pocky 数学期望

26 篇文章 1 订阅
24 篇文章 0 订阅

                                             Pocky

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 247    Accepted Submission(s): 119


 

Problem Description

Let’s talkingabout something of eating a pocky. Here is a Decorer Pocky, with colorfuldecorative stripes in the coating, of length L.
While the length of remaining pocky is longer than d, we perform the followingprocedure. We break the pocky at any point on it in an equal possibility andthis will divide the remaining pocky into two parts. Take the left part and eatit. When it is not longer than d, we do not repeat this procedure.
Now we want to know the expected number of times we should repeat the procedureabove. Round it to 6 decimal places behind the decimal point.

 

 

Input

The first line ofinput contains an integer N which is the number of test cases. Each of the Nlines contains two float-numbers L and d respectively with at most 5 decimalplaces behind the decimal point where 1 ≤ d, L ≤ 150.

 

 

Output

For each testcase, output the expected number of times rounded to 6 decimal places behindthe decimal point in a line.

 

 

Sample Input

6

1.0 1.0

2.0 1.0

4.0 1.0

8.0 1.0

16.0 1.0

7.00 3.00

 

 

Sample Output

0.000000

1.693147

2.386294

3.079442

3.772589

1.847298

 

题意:将一段长度为n的绳子多次切割,直到绳子长度不大于m,求切割次数的数学期望。

很尴尬的一道题,核心代码只有两行,但是不懂概率论无从下手。数学真的是软肋。

另外通过找规律可以发现:

(1.693147-1)*2=2.386294-1

(2.386294-1)*2=3.772589-1

可以退出跟2的对数相关,再加上一些细节,得到公式log(n/m)+1;

搬运大神的解析: 原址

代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<cmath>
#include<set>
#include<map>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
#define closeio std::ios::sync_with_stdio(false)
 
int main()
{
	int t;
	double n,m;
	cin>>t;
	while(t--)
	{
		cin>>n>>m;
		if(n<=m)
			printf("0.000000\n");
		else
			printf("%.6lf\n",log(n/m)+1);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值