Connect the Cities HDU - 3371

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  

Input

The first line contains the number of test cases. 
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities. 
To make it easy, the cities are signed from 1 to n. 
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q. 
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities. 

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.

Sample Input

1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6

Sample Output

1

思路:这道题也就是求最小生成树,只是将那些还相连着的城市的距离设为0就好

代码如下:

#include<bits/stdc++.h>
using namespace std;
const int INF =1e8+7;
int dis[505];
int mp[505][505];
bool vis[505];
int n,m,k;
vector<int>vec[105];
int prim()
{
    memset(vis,false,sizeof(vis));
   for(int i=1;i<=n;i++)dis[i]=mp[i][1];
   vis[1]=true;
   int minsum=0;
   for(int i=1;i<n;i++)
   {
       int mi=INF;
       int mii=-1;
       for(int j=1;j<=n;j++)
       {
           if(!vis[j]&&dis[j]<mi)
           {
               mi=dis[j];
               mii=j;
           }
       }
       if(mi==INF)return -1;
       minsum+=mi;
       vis[mii]=true;
       for(int j=1;j<=n;j++)
       {
           if(!vis[j]&&dis[j]>mp[mii][j])
           {
               dis[j]=mp[mii][j];
           }
       }
   }
   return minsum;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&k);
        memset(mp,0x1f1f,sizeof(mp));
        int a,b,c;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(mp[a][b]>c)
            {
                mp[a][b]=mp[b][a]=c;
            }
        }
        for(int i=0;i<k;i++)vec[i].clear();
        for(int i=0;i<k;i++)
        {
            int num,v;
            scanf("%d",&num);
            for(int j=0;j<num;j++)
            {
                scanf("%d",&v);
                vec[i].push_back(v);
            }
        }
        for(int i=0;i<k;i++)
        {
            for(int j=0;j<vec[i].size();j++)
            {
                for(int k=0;k<vec[i].size();k++)
                {
                    int a=vec[i][j];
                    int b=vec[i][k];
                    mp[a][b]=mp[b][a]=0;
                }
            }
        }
        int ans=prim();
        printf("%d\n",ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值