hdu3371 Connect the Cities(最小生成树)

http://acm.hdu.edu.cn/showproblem.php?pid=3371

Problem Description

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  

 

 

Input

The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

 

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.

 

Sample Input

 

1

6 4 3

1 4 2

2 6 1

2 3 5

3 4 33

 2 1 2

2 1 3

3 4 5 6

Sample Output

 

1

这个题目可以利用prim或者krukral,但是需要一点变形,

用prim时,将题目中给的已连接的点之间的距离变成0,

用kruksal时,可以先将已连接的点先并入集合中即可

附AC代码(kruskal):

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
#define maxn 1100
#define ll long long
#define INF 0x3f3f3f3f
int pre[1000],n,m,sum;
struct node{
    int start;
    int end;
    int val;
}v[26000];
bool cmp(node x,node y)
{
    return x.val<y.val;
}
int find(int x)
{
    int r=x;
    while(pre[r]!=r)//返回根节点r
        r=pre[r];
    int i=x;
    while(i!=r){
      int  j=pre[i];
       pre[i]=r;
       i=j;
    }
    return r;
}
void join(int x,int y)//判断是否联通
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
     pre[fx]=fy;   //合并
}
void get(int cur)
{
    for(int i=1;i<=m;i++){
        int fx=find(v[i].start);
        int fy=find(v[i].end);
        if(fx!=fy){
            join(v[i].start,v[i].end);
            sum+=v[i].val;
            }
    }
}
int main()
{
    int T,k,t,x,y;
    scanf("%d",&T);
    while(T--){
            scanf("%d%d%d",&n,&m,&k);
            sum=0;
        for(int i=1;i<=n;i++)
            pre[i]=i;
        for(int i=1;i<=m;i++)
            scanf("%d%d%d",&v[i].start,&v[i].end,&v[i].val);
            sort(v+1,v+1+m,cmp);
            for(int i=1;i<=k;i++){
                scanf("%d",&t);
                scanf("%d",&x);
                for(int i=1;i<t;i++){
                    scanf("%d",&y);
                    join(x,y);
                }
            }
            get(1);
            int l=0;
            for(int i=1;i<=n;i++){
                if(pre[i]==i)
                    l++;
                    if(l>1)
                        break;
            }
            if(l==1)
            printf("%d\n",sum);
            else printf("-1\n");
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值