HDU1241Oil Deposits(深搜)

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7296    Accepted Submission(s): 4262


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2
 
 
题目大意:给出一块地,这块地被分成n乘m的小方格,@代码下面有油田,*代表没有,如果相邻的两个方块下面都有油田,则算是同一个油田,问有多少油田。
思路:深度优先搜索,每找到一块小的独立的油田,则将与它相连的油田全部标记!
 
代码:
#include<stdio.h>
#include<string.h>
#define N 110
char s[N][N];
int n,m,count,vis[N][N];
int step[][2]={{-1,0},{-1,1},{0,1},{1,1},{1,0},{1,-1},{0,-1},{-1,-1}};
void DFS(int i,int j){
    int x,y,k;
	vis[i][j]=1;
    for(k=0;k<8;k++){
        x=i+step[k][0];
        y=j+step[k][1];
        if(x<0||y<0||x>=n||y>=m) continue;       
        if(s[x][y]=='@'&&vis[x][y]==0){
            DFS(x,y);
        }
    }
}
int main(){
    int i,j;
    while(scanf("%d %d",&n,&m),n){
        for(i=0;i<n;i++){
            scanf("%s",&s[i]);
        }
        memset(vis,0,sizeof(vis));
        for(i=0,count=0;i<n;i++){
            for(j=0;j<m;j++){
                if(s[i][j]=='@'&&vis[i][j]==0){
                    count++;
                    DFS(i,j);
                }
            }
        }
        printf("%d\n",count);
    }
    system("pause");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值