Python实现Pat 1034. Head of a Gang (30)

33 篇文章 0 订阅

题目

One way that the police finds the head of a gang is to check people’s phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A “Gang” is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:
8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10
Sample Output 1:
2
AAA 3
GGG 3
Sample Input 2:
8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10
Sample Output 2:
0

解答

def dfs(n):
    global visit,tree,gang
    for name in tree[n]:
        if visit[name]==False:
            gang.append(name)
            visit[name] = True
            dfs(name)

tree={}
visit={}
N,K=[int(x) for x  in input().split(' ')]
for i in range(N):
    a,b,c=input().split(' ')
    c=int(c)
    visit[a]=False
    visit[b]=False
    if a not in tree:
        tree[a]={}
        tree[a][b] = c
    elif b not in tree[a]:
        tree[a][b] = c
    else:
        tree[a][b] += c
    if b not in tree:
        tree[b]={}
        tree[b][a] = c
    elif a not in tree[b]:
        tree[b][a] = c
    else:
        tree[b][a] += c

cnt=0
heads={}
for n in visit:
    if visit[n]==False:
        #深度搜索确定帮成员
        gang=[]
        gang.append(n)
        visit[n]=True
        dfs(n)
        head=''
        maxw=0
        sum_w=0
        if len(gang)>2:  #more than 2
            for a in gang:
                weight=0
                for b in tree[a]: #计算各成员的权重
                     weight+=tree[a][b]
                if weight >maxw:
                     maxw=weight
                     head=a
                sum_w+=weight
            if sum_w/2 >K:  #sun_w在循环中计算了两次
                cnt+=1
                heads[head]=len(gang)
#将字典的所有项以列表返回,并对该列表进行排序
new_heads = sorted(heads.items(), key=lambda d:d[0], reverse = False)
print (cnt)
for item in new_heads:
    print (item[0],item[1])

这里写图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值