矩阵交换II HDU - 2830 (大概是个dp)

Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.

Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
Output
Output one line for each test case, indicating the maximum possible goodness.
Sample Input
3 4
1011
1001
0001
3 4
1010
1001
0001
Sample Output
4
2

Note: Huge Input, scanf() is recommended.


就当是dp了吧。

题目的意思是给你一个0 1 矩阵,让你去找到里面都是1的一个子矩阵,求出这个矩阵的面积,每一列都是可以交换的。也就是说行可以任意组合。

其实这个题就是暴力所有状态。

如果存在这么一个子矩阵,那么子矩阵一定是以给定矩阵的一行为下边界的。我们需要做的就是暴力下边界,对于每一个下边界,找到一个最大子矩阵。

示意图1.(枚举所有行)


具体枚举方法以枚举x1为例

之后要对每一个状态进行一波排序,这样我们就好确定他的面积最大值是多少,对枚举x1状态排序

这样之后再去确定面积,每一个纵坐标就是当前矩形的宽度,他的连续1的个数就是高度。

#include<bits/stdc++.h>
using namespace std;
char save[1010][1010];
int dp[1010][1010];
int maxans;
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        maxans=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%s",save[i]+1);
        }
        for(int i=1; i<=n; i++) //从第一行开始暴力
        {
            for(int j=1; j<=m; j++)
            {
                int sum=0;
                int ti=i;
                while(ti>=1&&(save[ti][j]-'0'))
                {
                    sum++;
                    ti--;
                }
                dp[i][j]=sum;
            }
            sort(dp[i]+1,dp[i]+m+1,greater<int>());
            for(int j=1; j<=m; j++)
            {
                if(dp[i][j]==0)
                    break;
                if(dp[i][j]*j>maxans)
                    maxans=dp[i][j]*j;
            }
        }
        printf("%d\n",maxans);


    }

}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值