The Accomodation of Students HDU - 2444 判断二分图

There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
Sample Input
4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6
Sample Output
No
3
判断二分图我们只需要从一个点开始跑,下一个点涂色为不同的颜色即可,如果下一个节点着色了,如果颜色与将要涂色相同,那么直接剪枝,否则返回0

判断完了二分图跑一遍匈牙利就可以了。

#include<bits/stdc++.h>
using namespace std;
const int M=1e5+10;
struct aa
{
    int u,v,next;
} edge[M];
int cnt,pre[M],team[M],used[M],mach[M];
void add(int u,int v)
{
    edge[cnt].u=u;
    edge[cnt].v=v;
    edge[cnt].next=pre[u];
    pre[u]=cnt++;
}
bool dfs(int now,int fa,int step)
{
    team[now]=step%2;
    for(int i=pre[now]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].v;
        if(v==fa)///等于父亲节点直接剪枝
            continue;
        if(team[v]==team[now])///涂色相同返回0
            return 0;
        if(team[v]!=-1)///如果涂色不同直接剪枝
            continue;
        if(!dfs(v,now,step+1))///之后的节点如果不成立返回0
            return 0;

    }
    return 1;///全部都成立返回1
}
bool findx(int u)
{
    for(int i=pre[u]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].v;
        if(!used[v])
        {
            used[v]=1;
            if(mach[v]==0||findx(mach[v]))
            {
                mach[v]=u;
                return 1;
            }

        }

    }
    return 0;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        cnt=0;
        for(int i=1; i<=n; i++)
            pre[i]=-1,team[i]=-1,mach[i]=0;
        while(m--)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            add(u,v);
            add(v,u);
        }
        int flag=1;
        for(int i=1; i<=n; i++)
        {
            if(team[i]==-1)
                if(!dfs(i,i,0))
                {
                    flag=0;
                    break;
                }
        }
        if(!flag)
            printf("No\n");
        else
        {
            int ans=0;
            for(int i=1; i<=n; i++)
            {
                if(team[i]==1)
                {
                    memset(used,0,sizeof(used));
                    if(findx(i))ans++;
                }
            }
            printf("%d\n",ans);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值