Ingenuous Cubrency UVA - 11137 题解

这篇博客介绍了Cubeland中使用立方形硬币作为货币的情况,详细解释了如何计算用立方硬币支付特定金额的不同方式。文章通过递推方法和优化策略来解决这个问题,并给出了样例输入和输出,展示了如何求解给定金额的支付方案数。
摘要由CSDN通过智能技术生成

People in Cubeland use cubic coins. Not only the unit of currency is
called a cube but also the coins are shaped like cubes and their values
are cubes. Coins with values of all cubic numbers up to 9261(= 213
),
i.e., coins with the denominations of 1, 8, 27, …, up to 9261 cubes,
are available in Cubeland.
Your task is to count the number of ways to pay a given amount
using cubic coins of Cubeland. For example, there are 3 ways to pay
21 cubes: twenty one 1 cube coins, or one 8 cube coin and thirteen 1
cube coins, or two 8 cube coin and five 1 cube coins.
Input
Input consists of lines each containing an integer amount to be paid. You may assume that all the
amounts are positive and less than 10000.
Output
For each of the given amounts to be paid output one line containing a single integer representing the
number of ways to pay the given amount using the coins available in Cubeland.
Sample Input
10
21
77
9999
Sample Output
2
3
22
440022018293


对数字找立方和组成方案总数。采用递推的方法,dp[i][j]表示最大数字为i,立方和为j的数字的组成方案数,可以通过三重循环i,j,k(i立方和的个数)递推,dp[i][j]+=dp[i-1][j-k*i^3];不过还可以用像背包dp里的优化方法来降复杂度,枚举k的过程的前k-1次在当前i且x小于j的dp[i][x]里都枚举过了,只需要+dp[i][j-i^3]再+dp[i-1][j]便可。

#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdio.h>
#include<vector>
#include<queue>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
const int maxe = 30005;
const int maxn = 10000;
const int maxk = 505;
const int mod = 1000007;
int n,m,k;
ll tri[22];
ll d[22][maxn + 1];
int main(){
    for (int i = 1; i <= 21; i++){ tri[i] = i*i*i; }
    d[0][0] = 1;
    for (int i = 1; i <= 21; i++){
        for (int j = 0; j <= maxn; j++){
            if (j >= tri[i])d[i][j] += d[i][j - tri[i]];
            d[i][j] += d[i - 1][j];
        }
    }
    while (~scanf("%d", &n)){
        printf("%lld\n", d[21][n]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值