Brackets POJ - 2955 区间dp

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im n, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end
Sample Output
6
6
4
0
6

又没想到,----------------

搜了一下是dp入门题,感觉比之前做过的两道题还难想

一天三道区间dp- -

说一下这个题,这个题就是跟着题目解释来就行了

难点就是循环顺序以及dp方程的建立

/*
按照题意
1.如果s是满足条件,那么【s】,(s)满足条件
2.如果a,b满足条件,ab满足条件,ba满足条件
3.空串满足条件
然后按照题意来就可以了
*/
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
char str[120];
int dp[120][120];
int main()
{
    while(scanf("%s",str+1))
    {
        if(str[1]=='e')
            break;
        int n=strlen(str+1);
        memset(dp,0,sizeof(dp));
        for(int i=2; i<=n; i++)
        {
            for(int j=i,k=1; j<=n; j++,k++)
            {
                if((str[k]=='('&&str[j]==')')||(str[k]=='['&&str[j]==']'))
                {
                    dp[k][j]=dp[k+1][j-1]+2;
                }
                for(int s=k; s<j; s++)
                {
                    dp[k][j]=max(dp[k][j],dp[k][s]+dp[s+1][j]);
                }
            }
        }
        printf("%d\n",dp[1][n]);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值