Dividing HDU - 1059 完全背包

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles. 
Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line. 
Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case. 
Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
Sample Output
Collection #1:
Can't be divided.

Collection #2:

Can be divided.

解法:

因为要两个人同时分配相等的总价值,所以这个值已经确定,并且如果一个可以那么两个人都可以了。

这样的话就转化为如果把一个人的价值分配出来,并且这个价值为v。

那么在完全背包中找到这样一个状态即可dp【x】=v,但是x未知,我们可以通过设置费用来达到x可知的目的,比如c【i】=v【i】,i的价值与花费相同,那么这时候x已知,x=v。

换句话说,如果可以分配,那么dp【v】一定等于v,否则一定不等于。

/*
完全背包>>>>>>>>01背包
*/
#include<bits/stdc++.h>
using namespace std;
int dp[500000];
int save[10];
int v;
void trans(int cost,int tot)
{
    int s=1;
    while(s<tot)
    {
        for(int i=v; i>=s*cost; i--)
        {
            dp[i]=max(dp[i],dp[i-s*cost]+s*cost);
        }
        tot-=s;
        s<<=1;

    }
    for(int i=v; i>=tot*cost; i--)
    {
        dp[i]=max(dp[i],dp[i-cost*tot]+cost*tot);
    }

}
int main()
{
    int kase=1;
    while(scanf("%d%d%d%d%d%d",&save[1],&save[2],&save[3],&save[4],&save[5],&save[6])!=EOF)
    {
        memset(dp,0,sizeof(dp));
        int sum=0;
        for(int i=1; i<=6; i++)
            sum+=save[i]*i;
        if(sum==0)
            break;
        printf("Collection #%d:\n",kase++);
        if(sum%2)
        {
            printf("Can't be divided.\n\n");
            continue;
        }
        v=sum/2;
        for(int i=1; i<=6; i++)
            trans(i,save[i]);
        if(dp[v]==v)
        {
            printf("Can be divided.\n\n");
        }
        else
        {
            printf("Can't be divided.\n\n");
        }

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值