2018 Multi-University Training Contest 1--Maximum Multiple--hdu--6298

Maximum Multiple

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1794    Accepted Submission(s): 769

Problem Description

Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).

Output

For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.

Sample Input

3

1

2

3

Sample Output

-1

-1

1

Source

2018 Multi-University Training Contest 1

题意就是给你一个数字n = X+Y+Z,然后要n整除x,n整除y,n整除z,同时xyz相乘最大,求xyz的值。

题解也很简单,因为一个数字要拆成三份只有三种情况:比如数字1

1.  \frac{1}{3}\frac{1}{3}\frac{1}{3}           2.\frac{2}{4}\frac{1}{4}\frac{1}{4}             3.\frac{1}{6}\frac{2}{6}\frac{3}{6} 

所以只要考虑这三种情况即可,同时能除6,就一定能除3,所以又排除一种,只有两种情况考虑就好。

Tips:一定要开longlong!

#include<bits/stdc++.h>
using namespace std;
int main() {
	long long int _,n;
	for(cin>>_;_;_--){
		scanf("%lld",&n);
		if(n % 3 == 0 ){
			printf("%lld\n",(n/3)*(n/3)*(n/3));
		}else if( n % 4 == 0){
			printf("%lld\n",(n/4)*(n/4)*(2*n/4));
		}else{
			puts("-1");
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值