Sightseeing trip(求最小环,记录路径)

Sightseeing trip
Time Limit: 1000MS Memory Limit: 65536K
Special Judge
Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route.

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, …, y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,…,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+…+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.
Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).
Output

There is only one line in output. It contains either a string ‘No solution.’ in case there isn’t any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.
Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20
Sample Output

1 3 5 2
题目大意:
有一些景点,一些景点之间存在一条路,求出从一个景点出发,经过至少两个景点(路径中不能有相同的点),再回到出发点的最短路径,输出路径(不唯一,有相同长短的路径,输出一条即可)
分析:
分析题意,用floyd算法求最小环,在求最小环的时候同时记录路径,此处,我用一个数组di[i][j]记录i到j的最短路径中经过的点,初始化di[i][j]=j,每求出一个最小环就要记录路径。
代码:

#include<iostream>
#include<algorithm>
#include<string.h>
#include<cstring>
#include<cstdio>
#define inf 10000000
using namespace std;
int dis[105][105],maze[105][105],di[105][105],dp[105];//dp记录路径
int ans,a,b,c,num;
int n,m;
void route(int a,int b)
{
    if(di[a][b]==b)
    {
       dp[++num]=b;
    }
    else
    {
       route(a,di[a][b]);
       route(di[a][b],b);
    }
}//递归将a到b的最短路途中经过的点存入di数组
void floyd()
{
    int i,j,k;
    for(k=1;k<=n;k++)
    {
       for(i=1;i<=n;i++)
       for(j=i+1;j<=n;j++)
       {
           if(ans>dis[i][j]+maze[j][k]+maze[k][i])
           {
               ans=dis[i][j]+maze[j][k]+maze[k][i];
               a=i;b=j;c=k;//c为途中最后一个景点
               num=0;
               dp[++num]=a;//a为途中第一个景点
               route(a,b);
           }
       }
       for(i=1;i<=n;i++)
       for(j=1;j<=n;j++)
       {
           if(dis[i][j]>dis[i][k]+dis[k][j])
           {
               dis[i][j]=dis[i][k]+dis[k][j];
               di[i][j]=k;//记录i到j的最短路途中经过的点k
           }
       }
    }
}
int main()
{
     int i,j,k,st,en,len;
     while(scanf("%d%d",&n,&m)!=EOF)
     {
         for(i=1;i<=n;i++)
         for(j=1;j<=n;j++)
         {
           di[i][j]=j;
           dis[i][j]=inf;
           maze[i][j]=inf;
         }
         ans=inf;
         for(i=1;i<=m;i++)
         {
             scanf("%d%d%d",&st,&en,&len);
             if(maze[st][en]>len)
             {
                maze[st][en]=len;
                maze[en][st]=len;
                dis[st][en]=len;
                dis[en][st]=len;
             }
         }
         floyd();
         if(ans<inf)
         {
           for(i=1;i<=num;i++)
           printf("%d ",dp[i]);
           printf("%d",c);
         }
         else
         printf("No solution.\n");
     }
     getchar();
     getchar();
     return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值