Max Sum(简单的最大子序列和的问题)

A - Max Sum
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example,
given (6,-1,5,4,-7),  the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines,
follow, each line  starts with a number N(1<=N<=100000), then N integers followed(all the integers are between 
-1000 and 1000). 
 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. 
The second line  contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, 
the end position of the sub-sequence.  If there are more than one result, output the first one. Output a blank 
line between two cases. 
 

Sample Input

     
     
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output

     
     
Case 1: 14 1 4 Case 2: 7 1 6

题目大意:求所给序列的最大子序列之和,并求出该最大子序列的首位和末位的位置。

分析:开一个dp数组记录以每位数字结尾的最大子序列之和,比较求出最大的子序列之和,并记录该子序列结尾的

           数字序号,从结尾数字向前累加,直到和等于求得的最大子序列之和,记录此时的数字序号,便是该最大子

           序列的首位。

注意:1,在第二个样例中,0作为最大子序列的首位。

           2,当最大子序列为一个数字时,首位与末位相同。

           3,最后一组结果后不需要空行。

代码如下:

#include<iostream>
#include<algorithm> 
#include<string.h>
#include<string>
#include<cstdio>
using namespace std;
int a[100005],dp[100005];
int main()
{
    int i,j,k,n,t,mm,nn,st,en,sum;
    scanf("%d",&t);
    for(i=0;i<t;i++)
    {
       sum=0;
       memset(dp,0,sizeof(dp));
       scanf("%d",&n);
       for(j=1;j<=n;j++)
       scanf("%d",&a[j]);
       dp[1]=a[1];
       for(j=2;j<=n;j++)
       {
          if(a[j]+dp[j-1]>a[j])
          dp[j]=a[j]+dp[j-1];
          else
          dp[j]=a[j];
       }
       mm=dp[1];
       nn=1;
       for(j=2;j<=n;j++)
       {
         if(dp[j]>mm)
         {mm=dp[j];nn=j;}
       }
       if(mm==a[nn]&&(dp[nn-1]!=0||nn-1<1))
       {st=nn;en=nn;}
       else
       {
         en=nn;
         sum=a[nn];
         for(j=nn-1;j>=1;j--)
         {
           sum+=a[j];
           if(sum==mm)
           {
             if(a[j-1]==0&&j-1>=1)
             st=j-1;
             else
             st=j;
             break; 
           }
         }
       }
       printf("Case %d:\n",i+1);
       printf("%d %d %d\n",mm,st,en);
       if(t-i>1)
       printf("\n");
    }
    getchar();
    getchar();
    return 0;
}

ps:第一次写博客,有错误望大家指出

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值