Wormholes【最短路fold-判断负环】

Wormholes

 POJ - 3259 

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题目大意:有n个农场,农场间有m条双向路,且有w个单向虫洞连接农场,第一行输入一个数字T,代表有T组测试数据,紧跟一行输入三个整数n,m,w,其下m行输入a,b两个农场之间有一条需要花费c时间的路,其后w行代表有一个从a到b的单向虫洞可以返回到c时间时间之前,问是否能够通过虫洞返回到开始出发之前。

解决方法:最短路问题,可以把正常的路存为正值,而通过虫洞的改为负值,判断是否会存在负边权即可,可以使用flod算法。

AC代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e3 + 5;
const ll mod = 1e9+7;
int n,m,w;
int mapp[510][510];
bool vis[maxn];
int dist[maxn];
int cnt[maxn];
bool flod()
{
	rep(k,1,n) {
		rep(i,1,n) {
			rep(j,1,n) {
				if(mapp[i][j]>mapp[i][k]+mapp[k][j])
					mapp[i][j]=mapp[i][k]+mapp[k][j];
			}
			if(mapp[i][i]<0)
				return true;
		}
	}
	return false;
}
int main() 
{
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    ios::sync_with_stdio(0),cin.tie(0);
    int T;
    cin>>T;
    while(T--)
    {
    	cin>>n>>m>>w;
    	rep(i,1,n) {
    		rep(j,1,n) {
    			mapp[i][j]=inf;
    		}
    		dist[i]=inf;
    		vis[i]=false;
    		mapp[i][i]=0;
    	}
    	rep(i,1,m) {
    		int a,b,c;
    		cin>>a>>b>>c;
    		if(c<mapp[a][b])
    			mapp[a][b]=mapp[b][a]=c;
    	}
    	rep(i,1,w) {
    		int a,b,c;
    		cin>>a>>b>>c;
    		mapp[a][b]=-c;
    	}
    	bool ju=flod();
    	if(!ju)
    		cout<<"NO"<<endl;
    	else
    		cout<<"YES"<<endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值